Saturday, March 24, 2012

A600: ClassicWB improvements

Free time on weekends to tinker my lovely Amigas is just priceless :)

This week there was a thread on EAB where we discussed about commodities while some fellow Amigans showed the need to use a Dock instead of plain icons "left out" on their Workbench screen.
Well I was one of them as well, since Workbench 3.1 doesn't have an AmiDock equivalent utility and every utility that I tried in the past wasn't nice for my taste.
Then it hit me that my old A2000 days I have used the ToolManager utility which worked like a charm. After so many years and trying to use it again, I found out that it was kind weird into setting it up. In some minutes I remembered how to set it up correctly and since some fellow Amigans asked if it would be possible for me to write a guide... I thought "Oh well... Lets do this"!

You can download the Guide that I wrote by clicking here.

An example of how my ClassicWB Full is now configured using ToolManager can been seen bellow.



The nice part is that apart of being pretty neat and nice, is that it's really configurable and most important... Blazingly fast! 

---------------------------

Some time ago I contacted Peter Keunecke (PeterK) asking him if there was a way to be able to use his awesome icon.library successfully on ClassicWB.
You see... before contacting him, I made all the necessary tests to my ClassicWB installation and for some reason loading PeterK's icon.library... messed with my palette and icons weren't showing at all!
After a lot of searching around I finally realized that it was the LoadWB that was causing the problems!
Scalos that all ClassicWB 3.1 packs use, uses it's own LoadWB command that internally uses the original LoadWB command (that is renamed to LoadWB.orig).
  • If I use the original WB3.1 LoadWB library then the icons using the new icon.library display just fine but I have no Scalos working.
  • If I use Scalos's LoadWB command then Scalos works just fine but I don't see the icons using the new icon.library.
After some fiddling around, PeterK sent me an archive with some file replacements on my ClassicWB installation that involved some new Classes/Datatypes/Libs/Prefs etc files and that way his icon.library worked just fine!!!
You can check it out along with a video from my previous article that I wrote some weeks ago here.

Seeing that it worthed the effort, Peter created a thread over EAB which explained everything you need to know.

Some days ago, he made a final revision of his archive which involved lotsa stuff. In the thread there is lot of details about what features his version had so whoever needs to make some reading... you can check it there :)

Since I have a really heavy modified ClassicWB installation I had to do my tests carefully so I decided that today was a nice day to do so.

Well after some time tinkering my installation around... IT WORKED LIKE A CHARM!!! 


These are some screenshots from AllIconsOnWB3.1 archive by PeterK showing OS4 icons and DualPNG Ken's Icons.




...and the new Icon information module from Scalos! How awesome is that!



Since my system is rather heavily modified with Custom Kickstart ROM... I made some minor alterations to PeterK's Startup-Sequence script:
  • I commented PatchRAM from the patches since I already have an "Ram-Handler 42.24" inside my Custom ROM.
  • I commented the LoadModule declarations for both Icon.library and SCSI.device as I have them in my Custom ROM.
  • I removed the PatchWB from my WBStartup folder since now it's in C and run from Startup-Sequence

Lotsa thanks Peter for your continuous work!

1 comment:

Chicks in Dubai said...

For Sexy and hot girls entertaining services
Dubai Escorts
call girls in Dubai