Saturday, August 27, 2011

A4000: Custom Delfina/USB Ethernet NIC mounting

OK this was an interesting Saturday so far!

After my previous thread of testing the Delfina I had to put it on permanent position along with the USB Ethernet adapter.
I was thinking about it the whole week so after I figured out how to do it... I had to find an old ISA Ethernet Card or an old ISA Soundcard...

My good friend Leo (Keropi) sent me yesterday an El'Crapo ISA Soundcard and an ISA ISDN Modem (lol) that I would salvage for my own modding needs :)

This is what the ISA ISDN Modem card looked like when I received it from Leo.

And that was what it looked like when I desoldered it's components and dremeled the whole area :)

Pretty spooky I know lol. Well I also cut the half of it (left part) cause I didn't need it and attached the Delfina via plastic spacers that I cut.

Btw, I forgot to tell ya that I drilled 3 new holes for my custom audio connector to back of the bracket and painted it to look better.

Some more detailed pics follow:

Ok it looked really nice. Time for the USB Ethernet NIC now... :)
First of all I had to drill a hole for the ethernet cable to be able to pass underneath the ISA card to reach the RJ-45 connector

...and then it was time to salvage/hack the D-Link USB Ethernet NIC.

...and after removing the Ethernet and USB connector... I attached the custom USB cable for the Deneb and the Ethernet mini cable that I attached from the adapter to the RJ-45 connector under the ISA card.

I really like it!!! I also putted some plastic spacers as well to keep the USB ethernet adapter in place so you can check out some more detailed pics bellow

Finally I had to mount it on the A4000 to give the combo a spin :)

Yep it works just fine... and what a better test than listening some good modules music from Eagleplayer (playing through Delfina's Line-IN) while surfing CSS content with Netsurf from my USB NIC :)

More stuff coming soon so stay tuned... \o/

Wednesday, August 24, 2011

A4000: Custom audio cabling and Defina testing

Yesterday I thought of giving a shot once more on my Delfina after 3 years having her :)
Well... tbh I have tested her on my previous A4000 where I had some freezing issues so I pulled her out and thought of testing it in the future...
...well 3 years after, the time has come and testing it on my ClassicWB 3.9 custom setup, IT WORKED LIKE A CHARM!!!

It was really awesome not to have any issues and all the mp3's that I tested worked just fine without a single glitch.
Take not that except from the latest delfina.library I also used the delfinampeg.device to be able to use Delfina to decode the mp3's without having my CPU doing that lol (yeah I know that I could use the WOS plugin of AmigAMP to have the PPC decode instead).

Amplifier didn't have a single issue and mp3 was really playing nice (even 256kbit playing from USB via Deneb).

Sadly though... I didn't have any cable to test it's input/outputs so I thought of waiting one day (meaning TODAY) to make some cables myself :)

First of all I desoldered an triple audio connector that I had on a dead PC mobo and mounted 3 cables with 4pin header on every connector. It may seem easy... but trust me... it's a real pain in the butt stripping and soldering these mini connectors...

Next one was a custom length, CD Audio connector after measuring it out.

And last but not least, the default A4000's audio output that needed to connect internally. You may not believe it but I soldered the cable near the A4000 cause I wanted it to pass through the tiny holes that exist for air flow on the right of Amiga!!! (Yeah I'm mental I know)

Here you can see the inside part of the cable with the thermal tube and the header

I was so thirsty to test it out that I only put some carton for insulation and gave it a spin!

- Audio OUT (Green connector) --> Works
- Line IN (Internal connector) = Amiga Output --> Works
- Aux1 IN (Internal connector) = CD Audio --> Works
- Aux2 IN (Blue connector) --> Works
- MIC IN (Pink connector) --> Haven't tested yet

At first nothing worked but I realized that all inputs had MUTE on LOL. After setting it correctly on Delfina mixer everything worked like a charm! I even put my SammichSID on Aux2 IN and it sounded awesome!

On the following picture you can see the programs I used to play simultaneously audio without a single problem.
- Amplifier (mp3)
- EaglePlayer (mod, via Amiga output to Line IN)
- PlayCD (CD audio, via CD audio out output to Aux1)

Not bad aye? Next step would be the permanent mounting on a custom bracket. That will require some time and effort but I'm in no hurry :)


Friday, August 19, 2011

A4000: Recapping CVisionPPC

As I showed in a previous thread some time ago, I changed one cap on my new acquired CVisionPPC that I got as faulty.

Thankfully... the cap was the problem that kept CVisionPPC from working on the previous owner.
Of course this replacement capacitor was only a temporary solution.

After setting up ClassicWB 3.9 and installing CGX4, AfAOS etc... I realized that I didn't pretty much liked the scrolling on screen. My 1280x1024 17" Dell screen worked just fine under my BPPC+BVision combo on my A1200 so it wasn't any issue with the Monitor.

Since my CVisionPPC has SMD electrolytic capacitors I thought of changing them with new tandalums since heat can dry them off pretty quickly. Also I realized that my previous CVisionPPC that I sold, as long as most pictures I saw over BBoAH and other forums had CVisions with tandalums as well.
I asked Cosmos if he had some (since here in Greece I couldn't find in my local electronics store any SMD component) and he sent me the required 7 caps that arrived today :)

So this is what the board looked like before the surgery (lol):

...and this is how it looks like after the recap:

It was a frightening experience for someone not as skilled in desoldering and soldering so small components but I managed to do it really smoothly.

Well there was only one way to find out if the surgery was successful... Fire it up and see what's coming :)

Result was SUCCESSFUL! Not only it looks a lot better but all the annoying scrolling and sizzling lines disappeared and the picture on my monitor is once more Crystal Clear!

Feels really good! And looks a lot better don't you think? :D

Sunday, August 14, 2011

A4000: Putting all together

After testing my A4000 for quite some time, I was expecting many components to be able to put all the Amiga together permanently (like accelerator spacers, 2.5" to 3.5" IDE adapter).

This Amiga sadly didn't have spacers for the accelerator (since it came with an stock 030@25MHz CPU).
I had 2 spare spacers from my previous A4000 but these were temporary solution since I wanted something more robust that could hold my CSPPC with screws.
Thankfully my friend Justin (JuvUK) sent me freely 4x spacers to use on my beloved accelerator (Man you rock!)

Here they are screwed on the lower side of A4000's motherboard

...and here they are from the upper side of the A4000's motherboard.

Accelerator screwed in it's place permanently (unless I decide to overclock or change the PPC CPU at some point = Stan the man)...

You will also notice in this photo the following:
  • 68060 fan being not center aligned on purpose due to the connector of CVisionPPC that requires a bit of space
  • PPC heatsink changed with an awesome copper one and a 30x30x10 noiseless fan
  • My beloved custom IDE cable that goes under CSPPC and goes right side near the PSU
  • The round Floppy cable that I stripped wire-by-wire on hand :)
Awesome airflow and not ugly ribbons all over the CPUs blocking the air (not to mention beautiful sight to watch lol).

This is the metal bracket with all the drives etc. You can clearly see the ACard with it's adapters along with the SCSI Multicarddrives.

After inserting the metal bracket that holds the drives... you can see that I have a really nice view and space even with the tight space that A4000 has.

On the side things get a little more squeezed but take in mine that there is plenty of room for the PSU fan to suck air to the back without cables blocking him.

If you noticed carefully you definitely saw the adapters train on the DVD-RW area :)
To enlighten you a bit the DVD-RW doesn't have anything weird but the custom yellow cable that comes from the IDE header.
The weird train comes from the 2.5" IDE Hard drive that sits under the DVD-RW (as you saw in a previous photo of mine) and consists of...
2.5" HD --> 2.5" to 3.5" IDE adapter --> ACard AEC-7220U --> 50pin to 68pin SCSI adapter and finally the SCSI 68pin cable from CSPPC's chain :)
Just to have better look here's the following pictures...

This is the 2.5" to 3.5" IDE adapter

...and this is the ACard with the 50pin to 68pin SCSI adapter

It's not noticeable that there's a custom mini cable with an male power connector that is soldered to the ACard and gives power to the 2.5" to 3.5" adapter. I forgot to take a picture of that but it was really need not to have another one power connector floating around :)

A view from the top can show you perfectly how it's all arranged together...

I'm pretty happy about how everything fitted without problems and that I haven't had to put extra money into acquiring an ACard!
This ACard was taken from my A1200 that from now on will be with her Idefix Express :) Sorry sister, my needs are huge...
I won't need to get an UW ACard in the future for the simple reasons that it's a lot bigger and won't fit as nice as this, and it's expensive not to have to think about it lol.

Just to see how well my ACard performs on the CSPPC's SCSI interface here's a photo of SysSpeed... 18.3MB/s yeah! \o/

Not bad for an SCSI-II interface (ACard AEC-7220U) don't you think?

More soon to come :)

Saturday, August 13, 2011

A4000: Deneb's custom cable

Ah Saturday :)

Since I woke up pretty early today I thought of doing some boring but essential stuff like making the custom USB cable that would go from Deneb to the USB header of my 5.25 bracket.

Since I don't like flat ribbon cables and I wanted 8 wire cable I salvaged one of my many UTP cables for the job. I measured the cable putting it in the path that I wanted and I was ready for some soldering. Connector's haven't been put straight to the cable but instead on a tiny veroboard to hold it steady on both ends. Ofc thermal tubing was attached for better stability.

I think it will be just fine for the job... Time to install to the 5.25 bracket's USB header.

...then putting the cable above the DVD-RW and follow Daughterboard's holder

...and finaly mounted on Deneb :)

Pretty neat don't you think? Finally I had to make some testing to check if both headers worked as they should!

Yep! It worked just fine in both USB positions! One more boring stuff done :)

Soon more to come.

Friday, August 12, 2011

A4000: Custom 5.25 bracket

From my previous A4000, I realized that good airflow and heat dissipation is rather difficult due to the not so spacy case and devices.
First of all CD/DVD-ROM units are rather big and along with the cabling makes it kinda messy.
I made a quick comparison back between the length of a normal DVD-RW and a slim DVD-RW.
Result was indeed amazing!

Ok I had to put it! Finding a 5.25 bracket back then wasn't easy and after a lot of searching around I found a really neat unit that has a spot for a slim CD/DVD unit, a spot for an 3.5 unit (floppy/multicard reader etc) and 2xUSB headers!
I quickly put a slim slot-in DVD-RW that I had along with a stock A4000 floppy to check it out! Not bad I'd say...

Well. After selling my A4000 and getting a new one... I came across the same issue as before but now I had the solution in my hands! In the following pictures you can see a test paint I used (which kinda suxed) along with a tray slim DVD-RW nice and neat Temperature/Fan control bracket that I bought.

I really liked the combo cause it's really good to know the temperature and fan speeds of my 060/PPC CPUs and VGA without being too kitsch.
It definitelly needed a good paint though cause that thing had so many colors... Ewww! Result was pretty perfect

I really like it and it works just fine! I found out that the Temp/Fan control bracket had also an Alarm per Temperature that you can set at will and also at a fan error (I tested it by pressing one working with a finger) you also get an alarm sound except the 0rpm message. NEAT!

The most awesome part though was that the bracket it's so thin that the 3.5" slot is almost empty!!! Time to take advantage of this extra space (as always lol).

This is the bracket of the default 2.5" HD for A600/A1200. Since I had 2 spare of these (nice to use CFs in my Amigas lol) I thought about modding it a bit for my needs.

...and now, you can place it inside the Temp/Fan bracket...

It fits like a glove! Also the cables for the Fan/Temp connectors/sensors were glued to the sides of the internal bracket.

Yep... the 2.5" Hard Drive is very well putted in it's bracket and it's ready for receiving it's own care... meaning an ACard!

More soon to come :)